Autotools requirements are too recent

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

Autotools requirements are too recent

Jeffrey Walton-3
$ autoreconf -f -i
configure.ac:35: error: require Automake 1.16.1, but have 1.15.1
autoreconf: automake failed with exit status: 1

Please consider dropping version requirements. I'm working on Fedora
28. Fedora is know for having some of the most up to date tools.

If something can't build on the latest Fedora there's no hope it can
build where a newer GNU Make is truly needed, like AIX 7, OS X 10.8,
Ubuntu 12, or Solaris 11.

(In fact I test some software back to Fedora 1 with GCC 2.9 and
Windows XP with Visual Studio .Net. Those are the machines I need to
update a handful of tools on. They won't have the bleeding edge stuff
Make is embracing).

Also consider, I could not care less if I have old Autotools. I don't
care if there's a bug or race during install. I'll live with the risk.
My job is to get a new Make on the machine, not dicking around with
Autotools versions. Anything that stops me from updating Make is a
distraction and waste of energy.

_______________________________________________
Bug-make mailing list
[hidden email]
https://lists.gnu.org/mailman/listinfo/bug-make
Reply | Threaded
Open this post in threaded view
|

Re: Autotools requirements are too recent

Martin Dorey-2

I did warn you.


Fedora is know for having some of the most up to date tools.


It must indeed be a cold day in hell, as I used automake 1.16.1 from Debian Buster.


 there's no hope it can build where a newer GNU Make is truly needed


Perhaps the widespread lack of this automake is what's behind any reticence Paul might be evincing about doing another release.  Probably not, though, as a release would give you a tarball that doesn't need autotools to build.


 I don't care if there's a bug or race during install.


If you want to engage constructively with the problem, you'll find a clue in:


http://git.savannah.gnu.org/cgit/make.git/commit/README.git?id=63b42fa235835cbeac6c1b9182f32798ea135dfd


I don't recall reading anything further than is there, but Google turned up:


Looks like you'd have to debug automake, which sounds... unpleasant.


From: Bug-make <bug-make-bounces+martin.dorey=[hidden email]> on behalf of Jeffrey Walton <[hidden email]>
Sent: Friday, August 24, 2018 4:46 PM
To: [hidden email]
Subject: Autotools requirements are too recent
 
$ autoreconf -f -i
configure.ac:35: error: require Automake 1.16.1, but have 1.15.1
autoreconf: automake failed with exit status: 1

Please consider dropping version requirements. I'm working on Fedora
28. Fedora is know for having some of the most up to date tools.

If something can't build on the latest Fedora there's no hope it can
build where a newer GNU Make is truly needed, like AIX 7, OS X 10.8,
Ubuntu 12, or Solaris 11.

(In fact I test some software back to Fedora 1 with GCC 2.9 and
Windows XP with Visual Studio .Net. Those are the machines I need to
update a handful of tools on. They won't have the bleeding edge stuff
Make is embracing).

Also consider, I could not care less if I have old Autotools. I don't
care if there's a bug or race during install. I'll live with the risk.
My job is to get a new Make on the machine, not dicking around with
Autotools versions. Anything that stops me from updating Make is a
distraction and waste of energy.

_______________________________________________
Bug-make mailing list
[hidden email]
https://na01.safelinks.protection.outlook.com/?url=https%3A%2F%2Flists.gnu.org%2Fmailman%2Flistinfo%2Fbug-make&amp;data=01%7C01%7CMartin.Dorey%40hitachivantara.com%7Cb72664bd6d264efc4eb008d60a1bd865%7C18791e1761594f52a8d4de814ca8284a%7C0&amp;sdata=CpbsZoGPg5TT%2FvE5%2BokmcLHHpv60zVO19WTbs0HXuow%3D&amp;reserved=0

_______________________________________________
Bug-make mailing list
[hidden email]
https://lists.gnu.org/mailman/listinfo/bug-make
Reply | Threaded
Open this post in threaded view
|

Re: Autotools requirements are too recent

Paul Smith-20
In reply to this post by Jeffrey Walton-3
On Fri, 2018-08-24 at 19:46 -0400, Jeffrey Walton wrote:
> $ autoreconf -f -i
> configure.ac:35: error: require Automake 1.16.1, but have 1.15.1
> autoreconf: automake failed with exit status: 1
>
> Please consider dropping version requirements. I'm working on Fedora
> 28. Fedora is know for having some of the most up to date tools.

I did not update this requirement because I wanted to.  Please see the
README.git file where I say:

> Unfortunately due to issues with gnulib's getloadavg, you must have
> automake 1.16.1 or above.  This version is not yet widely available
> in GNU/Linux package managers.  If you need to install from source be
> sure to set ACLOCAL_PATH to point to the pkg-config location (e.g.,
> /usr/share/aclocal).

I would love to back down to an earlier version of automake but before
that can happen the Gnulib getloadavg module needs to be fixed so it
works properly with older versions of automake.

Neither the Gnulib developers nor I have had the time or energy to
figure out what's wrong here.

You can find a thread about this issue here:

https://lists.gnu.org/r/bug-gnulib/2018-06/msg00024.html

(or I guess Martin already pointed to the salient message).

Cheers!

_______________________________________________
Bug-make mailing list
[hidden email]
https://lists.gnu.org/mailman/listinfo/bug-make