[bug #54161] Expansion of $$* is incorrect

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

[bug #54161] Expansion of $$* is incorrect

anonymous
URL:
  <http://savannah.gnu.org/bugs/?54161>

                 Summary: Expansion of $$* is incorrect
                 Project: make
            Submitted by: None
            Submitted on: Thu 21 Jun 2018 09:18:58 AM UTC
                Severity: 3 - Normal
              Item Group: Bug
                  Status: None
                 Privacy: Public
             Assigned to: None
             Open/Closed: Open
         Discussion Lock: Any
       Component Version: 4.2.1
        Operating System: Any
           Fixed Release: None
           Triage Status: None

    _______________________________________________________

Details:

The handling of $* is unexpected as it differs between the second expansion of
the targets and the recipe.


$ cat Makefile
.SECONDEXPANSION:
%x: $$(info $$*); : $*


For examples such as treated in the manual, this works as expected:

$ make fox
fo
: fo


However, following the suggestion about path treatment in implicit rules, the
following is unexpected:

$ make q/ux
u
: q/u


Observe the directory being stripped only in the expansion of $* in the target
listing, but not in the recipe.




    _______________________________________________________

Reply to this item at:

  <http://savannah.gnu.org/bugs/?54161>

_______________________________________________
  Message sent via Savannah
  https://savannah.gnu.org/


_______________________________________________
Bug-make mailing list
[hidden email]
https://lists.gnu.org/mailman/listinfo/bug-make
Reply | Threaded
Open this post in threaded view
|

[bug #54161] Expansion of $$* is incorrect

anonymous
Update of bug #54161 (project make):

                  Status:                    None => Fixed                  
             Assigned to:                    None => psmith                
             Open/Closed:                    Open => Closed                
           Fixed Release:                    None => SCM                    

    _______________________________________________________

Follow-up Comment #1:

Fixed via a patch from Jouke Witteveen.  Thanks!

    _______________________________________________________

Reply to this item at:

  <https://savannah.gnu.org/bugs/?54161>

_______________________________________________
  Message sent via Savannah
  https://savannah.gnu.org/